SSL Connection Issue
Incident Report for Haulix
Resolved
This incident has been resolved.
Posted May 02, 2022 - 17:12 CDT
Monitoring
We updated our system with a new SSL certificate and we're confirming the issue is resolved.
Posted May 02, 2022 - 17:00 CDT
Identified
This appears to be an issue with a recent Chrome (ONLY) update. We're still investigating...
Posted May 02, 2022 - 15:35 CDT
Investigating
We are currently investigating an SSL connection issue some customers are seeing in their browser.
Posted May 02, 2022 - 15:13 CDT
This incident affected: Website.