Promo Stat Graphs Temporarily Unavailable

Incident Report for HAULIX

Resolved

Promo stats are back up and getting refreshed again.
Posted Jun 27, 2025 - 06:33 CDT

Investigating

The system that computes the engagement graphs at the bottom of your dashboard is currently experiencing a temporary issue.
No data has been lost, and all your stats are safe. Your graphs will automatically refresh as soon as the system is back online.
Posted Jun 27, 2025 - 05:37 CDT
This incident affected: Website.